Lanc KB700 Merlin Problems

Discussion in 'Aircraft Pictures' started by prem895, Aug 11, 2017.

  1. prem895

    prem895 Active Member

    Joined:
    Oct 7, 2012
    Messages:
    1,164
    Likes Received:
    22
    Trophy Points:
    38
    Occupation:
    To stay under the governments radar
    Location:
    Toronto/Beijing
    #1 prem895, Aug 11, 2017
    Last edited: Aug 11, 2017
    I was at Hamilton the other day, and it seems as though they are still having a fair bit of trouble out of the far left port side engine, as the pictures show. I was here just 3 months ago and on that particular occasion they where giving the same engine a full run up. I have a short vid of that, but not sure if I will be able to download it. It was also sporting it's new scheme, but the picture i got is pretty crap. I will get more shots on the next short drive. You can also see a new rebuilt 5th powerplant.
     

    Attached Files:

    • 502.mp4
      File size:
      76.5 MB
      Views:
      12
    • 538.jpg
      538.jpg
      File size:
      1.3 MB
      Views:
      31
    • 541.jpg
      541.jpg
      File size:
      1.4 MB
      Views:
      29
    • 534.jpg
      534.jpg
      File size:
      1.8 MB
      Views:
      29
    • 535.jpg
      535.jpg
      File size:
      1.2 MB
      Views:
      31
    • 538.jpg
      538.jpg
      File size:
      1.3 MB
      Views:
      31
    • 533.jpg
      533.jpg
      File size:
      1.9 MB
      Views:
      34
    • 539.jpg
      539.jpg
      File size:
      1.8 MB
      Views:
      30
    • 1056.jpg
      1056.jpg
      File size:
      1.1 MB
      Views:
      26
  2. Old Wizard

    Old Wizard Well-Known Member

    Joined:
    Mar 26, 2008
    Messages:
    4,800
    Likes Received:
    288
    Trophy Points:
    83
    Location:
    Lethbridge AB
  3. Gnomey

    Gnomey World Travelling Doctor
    Staff Member Moderator

    Joined:
    Nov 28, 2004
    Messages:
    44,325
    Likes Received:
    687
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Doctor
    Location:
    Portsmouth / Royal Deeside, UK
    Home Page:
    Good stuff!
     
  4. Crimea_River

    Crimea_River Well-Known Member

    Joined:
    Nov 16, 2008
    Messages:
    27,267
    Likes Received:
    1,504
    Trophy Points:
    113
    Location:
    Calgary
    Thanks for posting. No idea what issue, if any, the engine has but running the engine occasionally doesn't necessarily mean there's a problem with it. Could be as simple as a leaky hose that they are trying to track down but it could also mean they are having some challenges.
     
Loading...
Similar Threads
  1. Lucky13
    Replies:
    29
    Views:
    2,133
  2. Milos Sijacki
    Replies:
    6
    Views:
    1,584
  3. rollie
    Replies:
    13
    Views:
    2,971
  4. KraziKanuK
    Replies:
    9
    Views:
    2,242
  5. Erich
    Replies:
    31
    Views:
    7,306

Share This Page